toyota forums   toyota forums

Go Back   Toyota Forum > Toyota Forums (Toyota Cars) > Toyota Matrix Forum


Toyota Forum: 06 Matrix code error
Thread Tools Display Modes
Old 04-21-2017, 11:20 AM
chetc chetc is offline
Junior Member
Join Date: Apr 2017
Posts: 1
Default 06 Matrix code error

I have a 06 Toyata Matrix, i purchased it new, car has 128K on it, replaced intake gasket at 97K, and check engine light came on yesterday same error po171 lean bank, is it possible the intake gasket went south in 30k miles, going to clean the MAF and check air filter, i have a cold air intake on it, been on there for 100K miles. any other things to check
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

All times are GMT. The time now is 01:03 PM.

cars connected social network

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc. recognizes that "Toyota", it's logos and various model names and numbers are registered trademarks of Toyota Motor Corporation. These terms are used for identification purposes only. is not affiliated in any way with Toyota Motor Corporation. or any other company listed herein. All information on this site is the opinion of its members and not the opinion of the site itself. ©2017 Madison Ross Media Group. All rights reserved. Content published on requires permission for reprint.
Need products for your Toyota? Check out your options at the links below: