toyota forums   toyota forums

Go Back   Toyota Forum > Toyota Forums (Toyota Cars) > Toyota Avalon Forum

Notices

Toyota Forum: runs like crap\
Reply
 
Thread Tools Display Modes
  #1  
Old 02-13-2017, 10:32 PM
trackfodder trackfodder is offline
Junior Member
 
Join Date: Feb 2016
Posts: 3
Angry runs like crap\

My 98 Avalon is having mixture problems apparently. It has a slow rolling idle and reluctantly will barely accelerate with much backfiring and surging. It will barely pull itself for awhile until it warms up. I just put about 1/2 can of B-12 Chemtool in a half tank of fuel HOPING it is sticking injectors. Any ideas?
Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT. The time now is 11:16 AM.


Advertisements
cars connected social network






Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
toyotaowners.net recognizes that "Toyota", it's logos and various model names and numbers are registered trademarks of Toyota Motor Corporation. These terms are used for identification purposes only. toyotaowners.net is not affiliated in any way with Toyota Motor Corporation. or any other company listed herein. All information on this site is the opinion of its members and not the opinion of the site itself. ©2017 Madison Ross Media Group. All rights reserved. Content published on ToyotaOwners.net requires permission for reprint.
MADISON ROSS MEDIA GROUP MARKETPLACE
Need products for your Toyota? Check out your options at the links below: